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Foreword

This	ebook	is	broken	into	the	following	six	secCons:

• Tools	and	Tips	for	a	WordPress	Professional.

• How	To	Use	InstantWP	Like	A	Power	User.

• How	to	create	an	InstantWP	duplicate	of	an	exisCng	WordPress	Website.

• How	to	move	an	InstantWP	installaCon	onto	the	Web.	

• How	to	Secure	an	InstantWP	installaCon	a`er	moving	it	onto	the	Web.

• TroubleshooCng	Your	InstantWP	MigraCons.

The first two chapters deal with background and setup and the rest of the

chapters	deal	in	detail	with	step	by	step	guides	to	each	topic.	
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5. How to Secure an InstantWP Installation after
Moving it onto the Web

5.1. Overview

InstantWP is great for running a WordPress website on your local computer but

it is inherently insecure. Any website based on InstantWP needs to be hardened

and secured once it is moved onto the web. This chapter outlines a few

housekeeping tasks you that should carry out to secure and op;mise your

WordPress installa;on once you have transferred your InstantWP installa;on

onto your web server. This will set a good basic level of security for any

website.

Most of the ;ps here involve installing and configuring simple WordPress

plugins. There are many more sophis;cated security plugins that do mul;ple

security tasks. You should take a look at some of these security plugins

available	for	WordPress	aTer	reading	this	chapter,	just	to	see	what	is	available.

Please note that some of the changes suggested below can some;mes go

wrong. You may lose Internet access halfway through a step, for instance. Your

WordPress installa;on could get broken. Always have a backup! If you are

following this ebook, then you s;ll have the Duplicator package as a backup.

But	in	other	situa;ons,	make	a	backup	before	making	these	changes.
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5.2. Note on Installing Plugins

Installing plugins in WordPress is easy, as you have seen from installing the

Duplicator plugin. The steps for installing all the plugins in this secCon are the

same, so rather than repeat them, here is a simple overview of WordPress

plugin	installaCon.

• You must go to the Plugins→Add New menu or the Add New bu9on at

the	top	of	the	Plugins	page.

• Type	the	plugin	name	into	the	search	box	on	the	top	right	of	the	page.

• The Search Results screen will be shown - select the plugin you want to

install	by	clicking	the	Install	Now	bu9on.	
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• The plugin will be downloaded from the WordPress website and once it has

finished	installing	you	can	click	the	Ac8vate	bu9on	to	turn	on	the	plugin.

• If the plugin has any adjustable sebngs, they are normally available from

within the SeSngs or Plugin menu (though occasionally some plugins use

the Tools menu too or a link from the Plugins page. See the specific plugin

documentaCon	for	details).
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5.3. Step by Step Guide

Step	1	-	Change	Administrator	Account	Name.

Leaving ‘admin’ as the username for the administrator account can be a

security risk. You can now change this to something different using the Admin

Renamer	Extended	plugin.

Once you have installed and acCvated this plugin the standard way, click on the

the Admin Renamer Extended link menu item on the Pluginsmenu. The plugin

will then show all administrator accounts - there should generally only be one

lisCng	for	your	WordPress	installaCon.

• Type in a new name for the administrator account (I have chosen ‘seamus’

as	shown	above).

• Click	the	Update	bu9on.

• You should log out and log back in with this new administrator account (the

password	will	sCll	be	the	same).
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Step	2	-	Update	Unique	Keys	in	your	wp-config.php	file.

The Update Unique Keys plugin makes your site harder to hack by adding

random elements to password encrypCon. These secret keys are stored in the

WordPress sebngs file wp-config.php. This is an older plugin but it sCll works

very	well.

You can begin by installing the Update Unique Keys plugin in the standard way.

The sebngs page for the plugin is available on the Sebngs menu. You just have

to	click	on	the	Update	bu9on.

	

This plugin will automaCcally set and update the WordPress hosted Unique Key

generator by adding new random values in the wp-config.php file. You must log

out	and	log	back	in	a`er	this	update.	
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Step	3	-	Change	Administrator	Account	Password.

You should now change the administrator account password to something

more	secure.		Go	to	your	profile	by	using	the	Users→Your	Profile	menu.

You can update your password at the base of this screen by clicking on the

Generate Password bu9on. WordPress will suggest a new password, you can

use	this	or	add	your	own.

Click on the Update Profile bu9on to save. You should memorise or make a

copy of the password before this of course! You should also log out and log

back	in	with	this	new	password	before	conCnuing.

InstantWP Unleashed Page 76

http://www.instantwp.com



Step	4	-	Change	WordPress	Database	Prefix	in	your	WordPress	database.

In some installaCons of WordPress, all the tables in the WordPress database

have the prefix 'wp' in the table name. This is a security risk as it allows hackers

to	guess	the	names	of	the	tables	in	your	site	more	easily.

You can rename the default WordPress tables in the database from having the

prefix ‘wp’ by using the Change Table Prefix plugin. Simply install the plugin in

the standard way and go to the SeSngs-->Click to Change Table Prefix menu

item.	

On the resulCng page just click on the Change Database Table Prefix bu9on.

This	will	fix	the	database	prefix	issue.	

InstantWP Unleashed Page 77

http://www.instantwp.com



Step	5	-	Prevent	the	WordPress	version	from	being	displayed.

The version of WordPress in your installaCon gets appended to various style

and script web addresses automaCcally. This can be a security risk as it allows

hackers to idenCfy what a9acks might penetrate the specific version of

WordPress you are running. In order to stop this, you should install the Meta

Generator	and	Version	Info	Remover	plugin.

Once installed, you can access the plugin sebngs via the SeSngs-->Meta

Generator	and	Version	Info	Remover	SeSngs	menu	item.	

You can then make sure that the Remove Meta Generator Tag, Remove

Version from Stylesheet and Remove Version from Script checkboxes are

Ccked	(this	should	be	done	by	default).

Just	click	on	the	Save	Changes	bu9on	a`erwards.
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Step	6	-	Stop	SQL	InjecCon	and	Bad	Query	A9acks.

SQL injecCon is a hacking technique that exploits security vulnerabiliCes

occurring in the database layer of a web site. Bad queries are specially

formulated malicious URL requests that can open security holes in a web

applicaCon.		Both	are	bad	news	and	both	should	be	stopped.

Install the BBQ: Block Bad Queries plugin to idenCfy and stop the most obvious

hacking a9empts against WordPress. This plugin is very simple and needs no

manual	adjustment,	it	just	works.

Once	installed	and	acCvated,	there	is	nothing	further	to	do.
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Step	7	-	Stop	Comment	Spam.

Comment spam is endemic on the Internet. You should install a plugin to filter

the	spam	comments	from	the	real	comments.

An8spam Bee is a free WordPress anCspam plugin that comes highly

recommended. Once installed and acCvated, you can find the AnCspam Bee

plugin menu under the SeSngs menu. The default opCons are a pre9y good

start	but	you	can	customise	them	if	you	wish.

Simply	click	on	the	Save	Changes	bu9on	here	to	stop	comment	spam.
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Step	8	-	Disable	the	WordPress	File	Editor.

WordPress comes with a built-in file editor that is quite useful for local

development (for instance when using InstantWP) but it can be exploited by

hackers. This tool is accessed via the Edit menu item under each plugin on the

plugins	page	for	instance.

It is recommended that you disable file ediCng within the WordPress

dashboard.	You	can	do	this	in	two	ways:

• WordPress	has	a	constant	that	disabled	this	ediCng	via	the	wp-config.php	

file.	Append	the	following	two	lines	to	the	end	of	your	wp-config	file:

##	Disable	Editing	in	Dashboard

define('DISALLOW_FILE_EDIT',	true);

• Or the easier opCon - just install the Disable File Editor plugin and acCvate

it.	You	will	see	that	the	Edit	menu	item	disappears.
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Step	9	-	Limit	Login	a9empts.

Your WordPress installaCon allows users to a9empt login as many Cmes as they

want. This can lead to hackers trying different usernames and password

combinaCons	unCll	they	get	one	that	works.	This	is	called	a	brute	force	a9ack.

The simplest way to stop this is to limit the amount of Cmes a user can login in

a specified Cme period. You can install the Login Lockdown plugin to take care

of	this	for	you.

Once you install and acCvate the plugin, you can access the Sebngs-->Login

Lockdown menu item and then check the plugin sebngs. The default values

are	generally	OK	and	you	can	just	click	the	Update	SeSngs	bu9on.
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Step	10	-	Check	your	permalink	sebngs.

The next two steps are more housekeeping steps than a security issues, but they

are	important	nonetheless	for	WordPress	to	func;on	correctly.

By default, WordPress uses URLs which have quesCon marks and numbers in

them which look ugly. However WordPress offers you the ability to create a

custom URL structure for your permalinks (short for "permanent link"). Go to

the	Sebngs	Permalinks	Screen	using	the	SeSngs→Permalink	menu	item.	

Make	your	changes	and	click	the	‘Save	Changes’	bu9on.

Tip:	A	simple	and	useful	permalink	structure	is	

%post_id%/%postname%/

This	will	provide	good	SEO	benefits	and	performs	well.
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Step	11	-	Update	your	URLs

A`er you move a WordPress website, some of your posts or pages may sCll

have the old website address listed in their contents or as links. If you install

and acCvate the Velvet Blues Update URLs plugin you can fix this problem. Go

to	the	Tools→Update	URLs	menu	item	to	get	to	the	plugin	sebngs	page.

These sebngs let you update your permalinks and any old URLs embedded in

content or excerpts. It will replace all occurrences of the old URL with the new

URL. Simply put the old website address in the top box (normally something

like h9p://127.0.0.1:10080/wordpress/ for InstantWP) and your new website

address	in	the	lower	box.	

Then	click	the	Update	URLs	bu9on.
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Step	12	-	Review	Your	Backup	Strategy.

Every website needs backups, but what sort of backups and how o`en depends

on the specific website. At the very least it is a good idea to take Cme out to

consider	what	your	website	needs.	

• You just need to think about what would happen if your website was hacked

or if there was a hardware failure in your hosCng company. Would you lose

money,	Cme	or	customers?	Is	there	a	potenCal	legal	issue	looming?

• How	o`en	should	you	do	a	backup?	Every	day?	Every	week?

• Do	you	need	an	offsite	backup	to	a	separate	service	like	Dropbox?

• Is	the	security	of	your	data	in	your	backups	important?

To start, take a look through the various backup plugins available for WordPress

and see what looks useful. There are many useful free plugins available and

you	really	owe	it	to	yourself	to	take	a	look,	before	you	need	to:

h9ps://wordpress.org/plugins/search/backup/
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5.4. Summary

You should now have a more secure WordPress installaCon. You should have

carried	the	following	tasks:

• Changed	the	administrator	account	name.

• Changed	the	administrator	account	password.

• Updated	the	unique	keys	in	your	wp-config.php	file.

• Changed	the	WordPress	database	prefix	in	your	WordPress	database.

• Prevented	the	WordPress	version	from	being	displayed.

• Stopped	sql	injecCon	and	bad	query	a9acks.

• Stopped	comment	spam.

• Disabled	the	wordpress	file	editor.

• Limited	login	a9empts.

• Checked	your	permalink	sebngs.

• Updated	your	URLs.

• Reviewed	your	backup	strategy.

If you are interested in learning more about securing WordPress, check out the

Hardening	WordPress	topic	in	the	WordPress	Codex:

h9p://codex.wordpress.org/Hardening_WordPress
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If	you	found	this	free	chapter	of	InstantWP	Unleashed

useful,	get	your	full	copy	of	InstantWP	Unleashed	now!
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InstantWP	Unleashed	Tes@monials

"Thank you so much for this really excellent so4ware - and for your generosity

in making it freeware. It is so simple to use and the fact that it runs so easily

from a usb s=ck makes it especially useful. The addi=on of InstantWP

Unleashed makes working with WordPress on localhost and then going live a

doddle!"

-	Charle	C.	(UK)

"A4er reading through the Ebook and checking out the videos, I am very

impressed with how well the topics are explained. You include the most basic

details, but also smoothly move into the more advanced areas with easy to

follow	instruc=ons.	"

-	Chris@e	H.	(Colorado,	USA)

“I purchased InstantWP Unleashed yesterday and had a chance to go through

the manual last night. I was really impressed with the step-by-step instruc=ons

and how thorough they were. ... If you have a WordPress Blog then you need

this	even	if	you	only	use	it	to	backup	and	restore	your	websites."

-		Lewis	S.	(Northern	Ireland)
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"A4er reading through the manual, it was a step by step guide with lots of

illustra=ons. There was a bunch of plug-ins he showed that I've never seen

before which I will be using to change out config files and vulnerable areas of

the security. Seamus has it laid out preMy easy so anyone can follow along. I

thought	I	had	a	preMy	good	knowledge	of	WP.		I	guess	I've	just	been	schooled!"

-	Jack	L.	(New	York)

Get	Your	Copy	of	InstantWP	Unleashed	Now:

h:ps://instantwp.com/unleashed/
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